OpenRoads Designer CONNECT Edition SDK Help

CreateTangentLineWithDirection Method

Constructs a profile Line element tangent to a profile element with direction.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  ProfileLine[]CreateTangentLineWithDirection( ProfileElement elmt, DPoint3d projEndPoint,double slope)

Parameters

SettingDescription
  ProfileElement The profile element which the created profile line is tangent to.
  DPoint3d The end point of the projected profile line(projected on the horizontal line passing by this point)
   The profile line slope

Return Value

ProfileLine[] The tangent profile line elements cli::array

See Also